Willowbrook, California
Not resolved
0 comments

When we ordered service I was told that due to a promotion Charter was having our installation would be free, however when we received our first bill, there was an installation charge for $29.99.I called and spoke to a rep who said they would issue me a refund but I still have not received it.

I also signed up for auto pay when we received our first bill, after we received our 2nd bill I noticed that auto pay never debited my checking account for our first month. I called Charter and was told that auto pay was not set up correctly and the routing and or account number was wrong. I then updated my auto pay and was assured it would be fine. Weeks later out service was off, when I called I was told it was because there had been 4 returned payments, the rep then told me that auto pay had attempted to debit the original auto pay account, I explained to the rep that we had updated our auto pay account and the repInformed me it takes 30-45 days to update.

Meanwhile Charter kept trying to debit the old account and charge me )$ 25 for each returned payment.Charter KNEW the first auto pay account was invalid that's why the helped me fix it and update the auto pay account with the correct routing and checking account info, however they kept charging the old account and charging me $25 for each payment that didn't go thru EVEN THOUGH they KNEW it wouldn't work.

Review about: Charter Communications Installation.

Had an Experience with Charter Communications?

Write a review

Comments

Terms of Service
Post Comment
Cancel

You May Also Like